Comments

L32 LogSync — 221 Comments

  1. Logsync no longer works. I made sure I had the latest version but its not working. Just hangs and doesnt give me an option on my call for uploads? Used to work fine
    Dave N8DC

  2. Rick after the last update 2.0.18 Logsync no longer shows my call or uploads any new contacts . It used to work fine. I have contacts in logger 32 marked to up load but it never does. I tell it to create the file and it has only all users the when I check the box and try to continue it tells me there are no qso’s marked for upload. It does download.
    Dave N8DC

  3. Dave..
    That part of the process is taking place in Logger32. Once you press the button to start the process Logsync passes the information to Logger32 that handles the export of the qso’s.
    In Logger32 right click on one of the qso’s and look to see what flags are checked. In order for Logger32 to show your call in the export qso’s routine there must be a flag sent that says for example if you are exporting to LOTW the Lotw Send flag should be selected. If that flag for any qso’s is not set then Logger32 will not show your call in the export window. Let me know if your qso’s show with a LOTW Send flag set. I am guessing that somehow the setting in Logger32 to always flag qso’s for export has gotten turned off.

    73 Rick N2AMG

  4. does l32logsync work on Win XP because for radio shark I use old computer
    thank you

  5. Rick, I recently upgraded Logsync from v16 to v18 and having no end of problems with it hanging, and not responding. Can you please send to me a copy of v16 again please.

    Thanks Rob G4UJS

  6. Hi Rob..
    Call it a stupid move on my part but I do not have a backup of v.16 When I created the build for the latest version I accidentally over wrote the v16 build files.
    What seems to be hanging on it?? Turn on the Debug log and let it run try to notice when it hangs and right after that turn the debug off let me see if I can find something in the debug file it is called DebugLog.txt just send that to me as an attachment..

    73 Rick N2AMG

  7. No it does not. All of the service that it uploads to and downloads from all use TLS 1.2 this is not supported in Windows XP.

    73 Rick N2AMG

  8. Hi Rick,

    Hope your well and dodging this pesky virus.

    I am getting on OK with v18 but one thing I notice is that I always run it minimised and sometimes after it has been running a while it will not maximise….even though it isa still uploading to website/HRD and EQSL quite happily. Cant maximise or close it from the task bar and only able to kill it with task manager if I want to. Using Win10 latest version.

    73 Rob G4UJS

  9. Hi Rick,
    I love LogSync! BUT…all of a sudden it stopped automatically uploading to LOTW. Upload to eQSL works just fine. It started about a week or so ago. Thoughts?

  10. With Logsync open Turn on Debug. and also open the LOTW setup window and there is a checkbox that says Diagnose TQSL. Place a checkmark in that box. Try logging a couple of qso’s when the uploads fail turn Debug off and and uncheck the diagnose TQSL checkbox and from the Logsync directory attach to an email to rellison@twcny.rr.com the these files: DebugLog.txt, Results.txt, And I think it’s name is diag.log (I’m not near my desktop right now) once I get them I should be able to tell you what the problem is..

    73 Rick N2AMG

  11. Just did an update and now L32 “cannot find QRZ lookup module.”
    thanks for a great program… a real service to the Ham community!
    Randy, KF4O

  12. okay, one problem solved.. I have another problem now… When I downnload, it does not set the LOTW received flag. Even after I restart, not seeing it. I did look at the adi file and the QSO is there, but not showing up in my log.
    sorry,
    Randy KF4O

  13. How are you downloading the file are you tell Logsync to download and import the file? When the file downloads Logger32 will ask you for the file to import have you made sure the path is correct?? Also what settings do you have set when the file gets imported. Depending on what you set in that box the comes up Logger32 might not update the log with the file. Also have you tried to manually import the file into logger32 by choosing Import LOTW file in Logger32??

    73 Rick N2AMG

  14. thanks for your quick reply..
    How are you downloading the file are you tell Logsync to download and import the file?
    At the bottom of the box, I click on Download LOTW QSL

    When the file downloads Logger32 will ask you for the file to import have you made sure the path is correct??
    It does not ask me, it says no new records and it tells me where it downloaded it to though

    Also what settings do you have set when the file gets imported.
    Not sure where to change settings

    Depending on what you set in that box the comes up Logger32 might not update the log with the file.

    Also have you tried to manually import the file into logger32 by choosing Import LOTW file in Logger32??
    Not sure how to do that.. tried exporting log, but it said was not an LOTW. Adi file..
    Sorry to be such a dummy

  15. “It does not ask me, it says no new records and it tells me where it downloaded it to though”
    LOTW told Logsync that there are no new qsl matches and it wrote what LOTW returned to the file that it shows you.
    Normally if you have qso’s downloaded Logger32 will prompt you for the file name that was downloaded. the file should already be selected so all you need to do is hit enter. At that point Logger32 will pop up a message window that will ask you how you want to import the file. After you answer the checkboxes then Logger32 will import your qso’s.
    But it sounds like you did not have any qso’s waiting.

    73 Rick N2AMG

  16. Hi Rick:

    I’m getting an error with both L32LogSynch and L32Lookups. The message is:

    A problem caused the program to stop working correctly.
    Please close the program.

    Followed by a button to close.

    This is new and perhaps Windows10 update related??

    Rick

  17. Rich,
    I am running Log32sync and it locks up regularly and I noticed it is from TCP input off of JTAlert and JTDX. I have the debug file I can send you.

  18. Hi Chuck..
    I would like to see the debug you can send it directly to rellison@twcny.rr.com as an attachment.
    I’m not sure how or why Logsync would lock up from JTAlert and JTDX. Logsync does not use TCP anyplace in it’s code. It communicates with Logger32 thru window messaging and creates new web ports to talk to any of the services that it uploads to.

    73 Rick N2AMG

  19. Running the L32LogSync v2.0.18, I get the following error message: Unhandled exception has occourd in your application. If you click Continue, the application…… etc. Errormessage say Conversion from string “14.12.2018 10:22:18” to type ‘Date’ is not valid. If I click Continue, the app works fine.

    Here is from debug:

    System.InvalidCastException: Conversion from string “14.12.2018 10:22:18” to type ‘Date’ is not valid.
    at Microsoft.VisualBasic.CompilerServices.Conversions.ToDate(String Value)
    at L32LogSync.Common.AutoCheckforUpdate() in F:\MySourceCode\Logger32\L32LogSync\L32LogSync\Modules\Common.vb:line 1096
    at L32LogSync.Main.UpdateTimer_Tick(Object sender, EventArgs e) in F:\MySourceCode\Logger32\L32LogSync\L32LogSync\Forms\Main.vb:line 7663
    at System.Windows.Forms.Timer.OnTick(EventArgs e)
    at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    I’m just curious if this is related to my setup. I’m running Win10 – latest version/patches. OS Language is English, Region United State, Regional format English(Denmark).

    I have tried uninstall / reinstall but got the same errormessage.

    73 de LA8AW Odd-Egil

  20. Hi Sorry for not approving this. I have been in and out of state more than I know where I am a lot of days..
    By looking at the date it is trying to convert I am thinking it has something to do with your regional settings..

    73 Rick N2AMG

  21. Hello Rick,
    when auto update QSO automaticaly after each QSO, lotw asks me to”Enter the password to unlock the callsign certificate”. Is there a way to stay always unlocked ? In the lotw setup (on L325LogSync) I entered my LOTW user name and password.
    Thank you
    valéry, f5idj

  22. Valery..In the LOTW setup window where it says private key. Enter in the password you use to unlock your certificate. This will get passed to TQSL so you should not need to input it any more..

    73 Rick N2AMG

  23. Today i take and install the 2.0.18 version on my pc .i have the logger32 version 3,50,423. i upload my logbook from the Club Log manual because from the N2AMG I can`t.Also i cant see live stream the qso`s on ClubLog .i think the synchronization don`t work.

  24. Kostas..
    Have you gone into each service you want to use and setup your information for each service?? On each tab there is a setup button that you need to click to setup your user information.
    If you have done that then click on Info then Debug then debug on. Try to upload to Clublog and after it fails Click Info/Debug/Debug Off. Located in the directory where you installed L32Logsync you will find a file called DebugLog.txt send that directl to my email (rellison@twcny.rr.com) as an attachment. I should be able to figure things out from that file..

    73 Rick N2AMG

  25. tonight I Sent to the email (rellison@twcny.rr.com) the DebugLog txt file dear Rick
    73 de SV2MAC Kostas

  26. Dear Rick today the the synchronization L32 & CLUBLOG work perfect and the live streaming also .i do all the setup.thank you for the help
    73 DE SV2MAC

  27. Hello ,i am using 3,50,424 version and 2.0.18 , for LOTW and EQSL, the Eqsl it works just fine. LOTW works fine on downloads ,but in upload I’m doing something wrong and does not work,what should i put in ? and ???
    I’m confused any help?

    Kostas sv2hjw

  28. Hello, I installed TQSL v2.5.7 and the l32 log sync won’t work. I only use qso to send to LOTW. I had to reinstall TQSL v2.5.4. It started working properly again. Is there a known cause of the problem? 73 SP2FNC Jaroslaw

  29. Logsync works fine with the latest TQSL. When you open Logsync click on the LOTW tab and then click Lotw setup. On that setup window there is a checkbox to diagnose TQSL problem. Check that box then close the window. Now on the Info menu you will find Debug Click that menu and select Debug On. Now do an upload to LOTW. After it doesn’t complete There are 3 files I need you to send to at rellison@twcny.rr.com Please send me from the directory where you have LogSync installed DebugLog.txt, L32Logsync.ini and Diag.log
    After I get them I will be able to tell you how to fix your issue…

    73 Rick N2AMG

  30. Kostas..
    Open Logsync and on the LOTW tab you will find a button called LOTW setup click that button and the setup window will open. On there you will find a checkbox called Diagnose TQSL issues. Check that box. Now close the setup window and in Logsync click the Info window and then Debug then Debug On. Try to upload a file to LOTW and after it fails I need you to send to me directly at reallison@twcny.rr.com 3 files located in the directory where you installed Logsync : Debuglog.txt, L32Logsync.ini and Diag.log after looking at them I should be able to figure out your problem..

    73 Rick N2AMG

  31. Hi Rick ,thanks for the info, the synchronization for LOTW is working fine.thank you very much . 73 sv2hjw

  32. First of all thanks for enabling this great app!!
    A suggestion on the LotW setup window:

    instead of using text above the 3d box ‘ Private Key (if used)’
    use text ‘ Passphrase to unlock the callsign certicicate’

    Because that is what it exactly says in T-QSL. I have no recollection if there is situations where you do not need this to get it uploaded.
    Took me some time to figure this out because I did not recall the wording ‘Private Key’ from LotW setup in the past.
    73 Mark PA5Mw

  33. I am having a problem when I download my LOTW confirmations. I do the logsync, and it comes up with “4 QSOs read” “0 records could not be imported”. Then under that it say “4 QSOs were updated”. I click OK. If I run the sync again, it still does the same thing, 4 QSOs read 0 records could not be imported and 4 QSOs were updated. It didn’t do this when I used the old LOTW EQSL sync. Any ideas?

  34. As I mentioned in the group this is an issue with the LOTW server. Logsync sends a command to the server that gives it certain params and the server responds.

    73 Rick N2AMG

  35. Hi. When I run LogSync it minimises onto the task bar and I cannot access the setup screen. Any ideas?
    Thanks.

  36. using Windows Explorer switch to the directory where the program is installed. in that directory open up L32logsync.ini by double clicking on it. When it opens up you should see the settings for WNDTop and WNDLeft set both of them to 100. Next look for the setting WNDWindowState and make sure it is set to 1. after doing that and saving the .ini file you can double click on L32LogSync and it should open to the Top left of the screen.

    73 Rick N2AMG

  37. 01/02/21 13:01:11 – Error- Main.DeleteQSOfromClubLog
    =Error Report=
    The remote server returned an error: (403) Forbidden.
    at System.Net.HttpWebRequest.GetResponse()
    at L32LogSync.Main.DeleteQSOfromClubLog(String PostData, String DXCall) in F:\MySourceCode\Logger32\L32LogSync\L32LogSync\Forms\Main.vb:line 5960
    =Error Report End=

  38. Hi Rick,
    I tried to delete a qso and clublog return qso not found.
    ——-
    01/02/21 13:01:11 – Error- Main.DeleteQSOfromClubLog
    =Error Report=
    The remote server returned an error: (403) Forbidden.
    at System.Net.HttpWebRequest.GetResponse()
    at L32LogSync.Main.DeleteQSOfromClubLog(String PostData, String DXCall) in F:\MySourceCode\Logger32\L32LogSync\L32LogSync\Forms\Main.vb:line 5960
    =Error Report End=
    ——
    tks 73 SV1VJ Giannis

  39. Giannis..
    Usally when Clublog returns a 403 error the username or password are not correct that is why it is saying forbidden.

    Here are the ClubLog returns info for the Delete command
    403 Forbidden: Access denied. This occurs if there are problems authenticating the delete or the basic prerequisites of the form are not met. The body will give information about what went wrong. The QSO will not be deleted.
    500 Internal error: You may see this if the delete call fails unexpectedly. In normal use this will not be seen.
    200 QSO OK: The QSO has been found, and deleted.
    404 QSO Not Deleted: The QSO data did not match a QSO, so nothing was deleted.

    73 Rick N2AMG

  40. Have about 50 QSO’s in Logger32 that show eQSL not sent and I cannot seem to update QSL_SENT in Logger32. L32LogSync displays a message saying these QSO’s have been sucessfully updated when I run the sync function.
    In the eQSL website, I can see those same QSO’s have been listed as correctly submitted.
    Details:
    I ran the eQSL download/sync process (lower right button in L32LogSync) several times. with the starting date to include the QSO’s in question. Here is one of the QSO records downloaded from eQSL by L32LogSync: (actual CALL is hidden)

    K0…202102022330
    20MFT8-03
    Y
    EDN88ee

    This shows a QSL was sent – by eQSL I assume. But the eQSL_SENT column in Logger32 never gets updated and still shows “N” for this particular date range of QSO’s.

    The rest of the QSO’s, both older and newer, are updated correctly, its just these in Feb 2-20 that don’t get the eQSL Sent set to Y.

    Any clue would be very helpful – the program is subperb otherwise.

  41. Doug..
    The eQSL flags do not get updated automatically when they are uploaded. There is experimental code in the program that tries to update the LOTW qsos after they get done processing but that code has some issues that I have been slowly working on. When uploading to eqsl you should get prompted by Logger32 to mark the qso’s as sent. You should select yes at that prompt. The only way to mark them correctly now is to right click on each qso and manually change the eQSL Send flag to false and the eQSL sent flag to true.

    73 Rick N2AMG

  42. Rick,

    Please ignore my post in the Bridge forum – I didn’t realize I was in the wrong place. I’ve also seen your very prompt reply to my question in this forum and I’ll give it a try. Thanks for a great program in any case!

    Doug

  43. Hi Rick! Still using 2.16 and it has been working just fine. Uploads are OK but when I try to download, when it goes to create the download file the name field is blank. If I try to manually enter a name and click download and synch it always comes back with no new records found regardless of what date I set. I was going to download the latest version but figured I’d wait on your response first as I see there seems to be a few issues with it as well. Thanks!

    Jim K2QB

  44. Hi jim..
    That is because QRZ changed the format of the html that indicates the Name field. I released a fix for that but they have done more changes in the same area. I have a fix for those changes coded but am still working on a couple more changes they did to the images and the biography fields..
    The version that is online here fixes the name issue but not for a lot of lookups that have recently started using html in the name filed those stations will not have the name picked up until I release these new changes..

    73 Rick

  45. Rick I guess I should have been clearer. I am referring to when I try to download records from LoTW or eQSL. Not sure what QRZ would have to do with it. Thanks!

    Jim K2QB

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

HTML tags allowed in your comment: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>